
 
 

 

TruckStop Express 
OPERATOR GUIDE 

November 2008 
  



 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  



 

 TruckStop Express Page 3 of 37 
 Operator Guide November 2008 • Rev. 1.2 

Table of Contents 
GETTING STARTED ..................................................................................................................................... 4 

 Minimum PC System Requirements .................................................................................................... 4 

 Programming Kit .................................................................................................................................. 4 

TRUCKSTOP EXPRESS SOFTWARE INSTALLATION .............................................................................. 5 

SETUP AND CONFIGURATION ................................................................................................................. 11 

TRUCKS ...................................................................................................................................................... 16 

 Creating a New Truck ........................................................................................................................ 16 

 Editing a Truck ................................................................................................................................... 20 

 Deleting a Truck ................................................................................................................................. 21 

USERS ........................................................................................................................................................ 22 

 Creating a New User .......................................................................................................................... 22 

 Editing an Existing User ..................................................................................................................... 24 

 Deleting a User .................................................................................................................................. 25 

READERS ................................................................................................................................................... 26 

 Loading User Data into the Readers .................................................................................................. 26 

HISTORY ..................................................................................................................................................... 28 

 Uploading History............................................................................................................................... 28 

 Viewing History .................................................................................................................................. 30 

 Sorting History Events ....................................................................................................................... 31 

 History Filter ....................................................................................................................................... 32 

REPORTS ................................................................................................................................................... 33 

 Create a User Report ......................................................................................................................... 33 

 Create a History Report ..................................................................................................................... 33 

APPENDIX I - LED AND BEEPER INFORMATION ................................................................................... 34 

 Un-Initialized Reader ......................................................................................................................... 34 

 Initialized Reader ............................................................................................................................... 34 

 Invalid User ........................................................................................................................................ 35 

 Activated Truck .................................................................................................................................. 35 

 Programming a Reader ...................................................................................................................... 36 

 Successful Data Transfer: .................................................................................................................. 37 

 Error on Data Transfer: ...................................................................................................................... 37 
 

 2008 Copyright Cansec Systems Ltd. 
All rights reserved. 



 

 TruckStop Express Page 4 of 37 
 Operator Guide November 2008 • Rev. 1.2 

Getting Started 

 MINIMUM PC SYSTEM REQUIREMENTS 

 One available USB port 
 CD-ROM disk drive 
 5 MB of free hard drive space 
 Microsoft Windows® XP or Windows® Vista 
 Adobe Reader 6.0 or greater 
 Internet Explorer 4.0 or greater 

 PROGRAMMING KIT 

The programming kit consists of four parts: 
 
 iButton® 
 USB ADAPTOR PROGRAMMING KEY 
 *Plugs into USB port *Snaps into Wand 

  
 
 
 
 

 
SOFTWARE WAND 
 *Mini CD *Plugs into USB Adaptor   
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TruckStop Express Software Installation 

NOTE: Do not plug in the USB adaptor until prompted to do so. 
 
1. Insert the TruckStop Express Software mini CD into your CD-ROM 

drive. 
2. Software setup should start automatically. 
3. If the software setup does not start automatically, manually begin setup: 

 Click START > Run 
 Type D:\setup.exe where "D" is the name of your CD-ROM drive 
 Click OK 

 
 
 
 
 
 
 

 
4. When the Installation Wizard appears, click NEXT. 
5. Make sure the Install iButton Drivers check box is checked.  
6. Click NEXT. 

 
 
 
 
 
 
 
 
 
 
 
7. When the 1-Wire Drivers Setup Wizard appears, click NEXT. 
8. When the Licence Agreement Window appears, select I AGREE. 
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9. Click NEXT. 
10.  Make sure the 1-Wire API for .NET and the OWCOM API  

options are NOT checked. 
 
 
 
 
 
 
 
 
 
 
 

11.  Click NEXT. 
12.  Unplug any 1-Wire® USB Devices and click NEXT. 
13.  The 1-Wire® drivers will be installed into the folder shown. To change 

the destination click BROWSE or type the destination folder in the 
appropriate field. 
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14.  Select the EVERYONE radio button and click NEXT. 
15.  Click NEXT to confirm the installation. 
16.  Wait while the drivers are installed. 
17.  When prompted, plug in the USB adaptor. Do NOT click OK. 
 
 
 
 
 
 

 
18. Windows will display the Found New Hardware Wizard. 
19.  Select the No, Not This Time radio button and click NEXT. 
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20.  Select Install the software automatically and click NEXT. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
21.  Click FINISH to complete the new hardware installation. 
22.  The Found New Hardware balloon will pop up on the taskbar. 
 
 
 
 
 
23.  On the 1-Wire® dialog box, press OK. 
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24.  The Port Selection window will appear. 
25.  Click AUTO DETECT. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
26.  Click OK. 
 
 
 
 
 
27.  Wait while Windows® detects your port settings. 
28.  Click YES to accept the port selection. 
 
 
 
 
 
 
29.  The 1-Wire® driver installation is complete.  
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30.  Ensure that the USB Host Adaptor for 1-Wire® Network is detected 
under 1-Wire Devices. (Device Manager / Computer Management) 

31.  Click CLOSE. 
 

32.  On the TruckStop Express Installshield Wizard, click INSTALL. 
 
 
 
 
 
 
 
 
 
 
 
 
33.  Wait while Windows® installs the TruckStop Express software. 
34.  Click FINISH to complete the installation. 
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NOTE: The password can be a maximum of 8 alpha-numeric characters and 
is case sensitive.  The password is used to ensure TruckStop Express 
controllers from one site can only be  programmed by the software belonging 
to that site. 

Setup and Configuration 

 
1. Click on Start > All Programs > TruckStop Express > Launch 

TruckStop Express. 
2. Click OK to define a password and USB adaptor serial number. 
 
 
 
 
 
 
 
 
 
 
3. Type a new password. 
 
 
 
 
 
 
4. Click LOAD to load the USB adaptor serial number. 
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Make sure the USB adaptor drivers are installed and the USB adaptor is 
plugged into a USB port.  Registration of the USB adaptor serial number is 
required for correct operation of the software.  Each USB adaptor has a unique 
serial number.  If you ever replace the USB adaptor with a different one, you 
must load the new serial number into the software. 

 
 
 
 
 
 
 
 
 
5. Click OK. 
 
 
 
 
 
 
 
6. Click OK. 

 
 
 
 
 
 
 
 
 
 

 
 
 

NOTE: The USB serial number is a unique 16-character number. 
Example: BB00000027BE5F81 

  

 XXXXXXXXXXXXXXXX 
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7. The Truck View Help screen will appear. Read through the tips. 

 
 
 

8. Check the Don't Show this Message Again box and click OK. 
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9. Click USERS from the Menu Bar to view the Users View Help screen. 

 
 
 

10. Check the Don't Show this Message Again box and click OK. 
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11.  Click HISTORY from the Menu Bar to view the History View Help 
screen. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

12.  To view the help screens at a later time, click Help > Screen Tips. 
 
 
 
 
 
 
 
13.  Check the Enable/Reset all screen tips check box and click OK. 
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Trucks 

Each lift truck is fitted with an iButton® or Wiegand proximity reader. After 
turning the lift truck key in the ignition, users present their iButton® user 
keys or proximity cards to the readers before attempting to start the lift truck 
engine. Follow the steps below to create "virtual trucks" to represent each 
reader.  
 
NOTE: Trucks must be created before creating any users. 

 
 
 
 
 
 
 
 

 CREATING A NEW TRUCK 

1. Click  
 

2. From the Menu Bar, select Edit > New. 
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3. The following window appears: 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
4. Enter the required information in the Identification section. 
 

 ID:  Each truck must be assigned a unique ID number from 1 – 256. 
 NAME:  Give each reader an appropriate, unique name. 

 
5. Enter the New Reader Time in the Create a Setup Programming Key  
    section. 
 
NOTE: Each reader must be programmed with the correct time. You can 
manually adjust the time by entering a new value or by using the arrows to 
the right. The time shown in the window is not automatically updated as 
time passes, so consider the amount of time it will take to bring the 
programming key to the reader, and adjust the time accordingly. If it will take 
you 5 minutes between the time you create an programming key and the time 
it takes to reach the lift truck, set the time 5 minutes ahead of the current 
time. 
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6. Load the programming key by snapping it into the wand. 

7. Click .   
 

 
 
 
 
 
 

 
  

NOTE: TruckStop Express does not adjust for Daylight Savings Time 
automatically. The time must be updated manually.  See Editing a Reader. 
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The following data is loaded when you create an programming key in SETUP 
mode: 

 User-defined password 
 Reader ID number (1-256) 
 Clock (date and time)  

 
 
 
 
 
 
 
8. Remove the key from the wand. 
9. Take the key to the appropriate lift truck. 
 
 
 
 
10. Hold the programming key to the iButton® reader. 
 
 
 
 
 
 
 
 
 
 
11. You will hear a a long beep from the reader. When the beep stops, setup 
is complete and you may remove the key from the reader. See Appendix I - 
LED and BEEPER information for details. 
 

  

NOTE: The reader ID number is attached to the events that happen on 
that specific lift truck.  This information will be displayed when you upload 
the history file of that lift truck. The reader name is only used by the 
software for reference.   

NOTE: When the reader is in factory default mode, it will beep 
continuously and the LED will flash red and green. 

NOTE: For accurate auditing you must create a new setup programming 
key for every reader. 
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 EDITING A TRUCK 

 

1. Click  

2. Select the Truck  you wish to edit. 
3. From the Menu Bar, select Edit > Edit.   
 
 
 
 
 
 
 
 
 
4. Make changes as necessary.   
 
NOTE:  If you change the ID and/or the time, create a new programming 
key in SETUP mode and present it to the reader. If you change the name 
only, a new setup key is not needed. 
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 DELETING A TRUCK 

 

1. Click  

2. Select the Truck  
3. From the Menu Bar, select Edit >Delete. 

  
 
NOTE: If you are removing a lift truck from the fleet in which the operating 
personal can operate, you may want to edit the user’s who have access to the 
lift truck and re-program the truck. 
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Users 

Users are your lift truck operating personnel.  Each user is to be assigned a 
user key which has an internally stored ID number.  This number will be 
loaded and stored into the software under the user’s properties.  You will 
also determine which lift trucks (if any) the user’s key will have access to 
operate.  This information will be programmed into the readers.   
 
 
 
 
 
 
 
 
 

 CREATING A NEW USER 

 

1. Click  
2. From the Menu Bar, select Edit >  New.   
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3. The User Properties window appears: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
4. Enter the appropriate identification information: 
 
ID - Enter the ID number for each iButton® user key assigned to a user by 

snapping the key into the wand and clicking . If proximity cards 
are used, enter the 10 digit card ID. Prefix the card ID with zeroes if 
necessary to make 10 digits. 

NAME - Enter the name of the user.  Full names should be used and all 
names should be entered in the same format (such as “lastname, firstname”). 

INFORMATION - Filling out these fields is optional.  You may enter any 
information related to the user. 

TRUCK ACCESS - Select the lift trucks that the user may operate by placing 
a check in the box beside each appropriate lift truck.  If the box is left 
unchecked, the user will not have access to that lift truck. 

5. When you are finished, click  . 

NOTE: if you attempt to enter an ID number that already exists, the 
following error message will be displayed: "A record with this ID already 
exists." The ID and name will also be displayed.  
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 EDITING AN EXISTING USER 

 

1. Click  

2. Select the user  
3. From the Menu Bar, select Edit > Edit. 

 
 
4. Edit the user as necessary. 
 
NOTE:  If you have issued a new user key to the user, all lift trucks the user 
has access to need to be re-programmed with the new ID number. If you have 
changed which lift trucks that the user has access to, the affected lift trucks 
need to be re-programmed.  For example, if you change Driver 1 from 
“having access to Truck 1” to “not having access to Truck 1”, only Truck 1 
will need to be re-programmed. 
 
If you change the name or the information of a user no re-programming is 
necessary.  This information is only stored in the software for reference only. 
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 DELETING A USER 

 

1. Click  

2. Select the user  
3. From the Menu Bar, select Edit  > Delete.   
 

 
 
NOTE: The lift trucks that the deleted user had access to need to be re-
programmed.  Otherwise the deleted user’s key will still be able to operate 
the lift truck. 
 
NOTE: to delete multiple users, select all users you wish to delete and press 
the delete  
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Readers 

When you program a lift truck, you will load all user data into the reader so 
that it will know which users have access to operate the lift truck.  Any time a 
new user is created, edited or deleted the readers must be re-programmed 
accordingly.   

 LOADING USER DATA INTO THE READERS 

1. Click  

2. Select the truck reader to program  

3. From the Menu Bar, select File >   .   
4. The following window appears: 
 
 
 
 
 
 
 
 
 
 
 
 

5. Snap the programming key into the wand and click .   
6. The software will load the list of users for the selected lift truck into the 

programming key.   
7. When the programming key (in USER mode) has been successfully 

created, click OK and then click .   
8. Remove the programming key from the wand and bring the key to the 

appropriate lift truck.   
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9. Hold the key to the iButton® reader. 
 

 
 
10.  You will hear a series of beeps from the reader. When the sounds stop 

(after about 3 seconds) programming is complete and you may remove the 
key from the reader. See Appendix I - LED and BEEPER information for 
details. 

 
NOTE: You can use the loaded programming key at other readers if the user 
data is identical to this reader. 
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History 

The TruckStop Express controller stores a history file of the last 100 events 
that took place on the lift truck.  You may extract and view this data at any 
time. 

 UPLOADING HISTORY 

1. Click  

2. From the Menu Bar, select File >    
3. The following window appears: 
 

 
 

4. Snap the programming key into the wand and click  
5. When the programming key is cleared and ready to take data history from 

a reader, detach the programming key from the wand 
6. Hold the programming key to the iButton® reader. You will hear a series 

of beeps from the reader.  When the sounds stop (after about 3 seconds), 
upload is complete  
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7. Snap the programming key into the wand at the PC 
8.  In the History Upload window, click on the Upload Reader History tab 
9. Choose the desired date from the drop-down menu 
 
 
 
 
 
 
 
 
 
 
 
 
 
You can click on the  left and  right arrows on either side of the 
displayed month and year to cycle through each month.  By clicking on 

, the current date will be selected.  By clicking on  no date will 
be selected and all 100 transactions will be uploaded.   
 

10.  Snap the programming key into the wand and click  
 

11.  When you are finished, click  
 
12.  The history files are now uploaded. To view the history files, follow the 

instructions on the following page 
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 VIEWING HISTORY 

History files are saved in an “ID, Date, Time” format.  This is to quickly 
show you which lift truck the history file is from as well as the date and time 
the history file was uploaded into the software. 
 

1. Click  

2. Choose a file from the pull down menu  

3. From the Menu Bar, select View >    

4. The chosen audit file will be displayed 
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 SORTING HISTORY EVENTS 

To rearrange history events into chronological order, use the database re-
index tool: 
 
1. Click File > Database Re-Index 
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 HISTORY FILTER 

1. Click  

2. Choose a file from the pull down menu  

3. Select View >    
4. The following window will appear: 
 

 
 
5. Select the start and end times.  Events that occurred within this range will 

be displayed in the report. 
6. Select Lift Truck Event Type(s) to include.  Checking the box will include 

those event messages in the report. 
7. Optional: enter an ID selection.  This allows you to search for the events 

of the users based on their ID number.  If you enter a partial ID string 
(example: 00123) it will search for all users whose ID starts with that 
partial string. 

8. When you are done making your selections, click  
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Reports 

 CREATE A USER REPORT 

1. Click on USERS. 
2. From the Menu Bar, select File > Report 
 
 
 
 
 
 
 
 
 
3. The report will open in Notepad. You can print and/or save the file 

 CREATE A HISTORY REPORT 

1. Click on HISTORY. 
2. From the Menu Bar, select File > Report 
 
 
 
 
 
 
 
 
 
3. The report will open in Notepad. You can print and/or save the file 
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Appendix I - LED and Beeper Information 

The TruckStop Express reader is directly connected to the lift truck's battery 
power source. Operation of the unit requires the following steps:  

1. turn the ignition on 
2. present a valid user key or proximity card 

 
The TruckStop express reader has two modes: ignition OFF and ignition 
ON, each generating different LED and BEEPER indicator behaviours. 

 UN-INITIALIZED READER 

Status: IGNITION OFF or IGNITION ON 
 LED: flashes red and green continuously 
 BEEPER: beeps continuously 

 
Solution: Reader must be initialized using a programming key (in SETUP 
mode) 
  
Result: After the programming key is read and loaded into the reader: 

 LED: solid red (ignition ON) or flashing red and green (ignition OFF) 
 BEEPER: stops beeping 

 INITIALIZED READER 

Status: IGNITION OFF 
 LED: stays red 
 BEEPER: sounds 3 times on presentation of credential 

 
Solution: Ignition is OFF. Turn ignition ON before presenting credentials. 
 
NOTE: The LED and BEEPER indicate proper or improper attempts to 
operate the vehicle. This applies for both valid and invalid users, when the 
ignition is OFF. 
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 INVALID USER 

Status: IGNITION ON 
 LED: stays red 
 BEEPER: beeps 2 times on presentation of credential 

 
Solution: In-valid user. Present credentials for a valid user. 
 
Result: On presentation of credential for a valid user: 

 LED: goes green 
 BEEPER: beeps 1 time 

 ACTIVATED TRUCK 

Status: IGNITION ON 
 LED: stays green 
 BEEPER: beeps 5 times 

 
Solution: The truck has already been activated by a valid user 

  



 

 TruckStop Express Page 36 of 37 
 Operator Guide November 2008 • Rev. 1.2 

 PROGRAMMING A READER 

NOTE:  The programming key can be read by the reader whether the 
ignition is OFF or ON. 
 
Status: Programming key presented to reader 
LED: stays red 
BEEPER: gives a 3-second warble tone 
 
Solution: Bad read. Re-apply the programming key 
 
NOTE: If error persists, there may be a password mismatch or unstable read-
head contact. 
 
 

The programming key has three modes: SETUP, USER and AUDIT. 
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 SUCCESSFUL DATA TRANSFER: 

Status: Programming key presented to reader 
 LED: turns green and stays green for 1 second after beep has stopped 
 BEEPER: sounds briefly  

 
Solution: Successful data transfer 
 
NOTE: The programming key will have different data transfer times 
depending on the mode. The longest data transfer time is approximately 3 
seconds (for AUDIT mode). 
 

 ERROR ON DATA TRANSFER: 

Status: Programming key presented to reader 
LED: stays red 
BEEPER: gives a 3-second warble tone 
 
Solution: Bad read. Re-apply the programming key  
 
NOTE: If error persists, there may be a password mismatch, unstable read-
head contact, or the programming key may have been removed before the 
data transfer was completed. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
® iButton is a registered trademark of Dallas Semiconductor Corp. 
® 1-Wire is a registered trademark of Dallas Semiconductor Corp. 


